首页 常见问题 WordPress程序PhP版本太低怎么办

WordPress程序PhP版本太低怎么办

最近有不少外贸建站站长反应,自己的WordPress程序PhP版本太低怎么办,那么本文就来好好给大家介绍一下,操作环境WindoWs7系统、WordPress5.4.2版,DELL G3电脑。

解决WordPress程序PHP版本过低的方法和思路

如果我们比较关注WordPress程序新版本的话会看到自己在网站后台提示有新的WordPress程序需要升级的时候,如果我们当前的WEB系统PHP版本低于5.6版本是无法点击按钮在线直接升级的。因为从WordPress5.2版本开始需要最低PHP5.6,而且根据官方提供的信息可能后面会要求PHP7.x+。

也就是说,如果我们在使用WordPress程序的时候,如果希望用到新版本,你必须是PHP5.6+,如果不升级你是无法使用新版本WP的,就这么任性。那如果我们当前WEB系统不支持PHP5.6+如何办呢?

第一、如果我们是虚拟主机

如果我们使用的是虚拟主机,比如是cPanel面板的话,一般商家都是支持在线调整PHP版本的。我们需要登录cPanel面板,然后在PHP版本设置中选择当前站点,然后选择需要调整的PHP版本。我们需要检查当前网站主题、插件是否支持设置的PHP版本,有些网友喜欢选择最高PHP7.3,但是有些插件或者主题不支持,那我们就适当的调低。

第二、如果我们是服务器

如果我们是服务器,我们需要看看自己的WEB套件是否支持安装多版本PHP软件。比如我们是安装的宝塔面板,或者其他WEB面板是可以安装多版本PHP版本的。(参考:宝塔面板安装多PHP版本切换及不同站点设置不同PHP环境)在安装PHP版本之后对站点进行PHP选择更换。

同样的我们需要检查主题和插件是否兼容。不过,如果我们是自己编译的WEB系统,我们需要手动调整,如果自己不熟悉的话,建议还是老老实实备份数据后重新格式化后安装WEB系统套装。个人建议,目前PHP可以安装到7.2版本或者直接升级到PHP7.3最新,目前也是稳定版。

以上就是关于WordPress程序PhP版本太低怎么办介绍,但是这里还是建议广大外贸建站站长将WP升级到最新版本,因为涉及到安全问题。

推荐:《WordPress是什么开发的及支持什么数据库

免责声明:文章内容不代表本站立场,本站不对其内容的真实性、完整性、准确性给予任何担保、暗示和承诺,仅供读者参考,文章版权归原作者所有。如本文内容影响到您的合法权益(内容、图片等),请及时联系本站,我们会及时删除处理。

为您推荐

Ueeshop和WordPress哪个更适合跨境电商建站?

WordPress是一个博客平台,用户可以运用WordPress在支持PHP和MySQL数据库的服务器上建设属于自己的网...
跨境知识:Shopify费用包括哪些?Shopify费用详解

跨境知识:Shopify费用包括哪些?Shopify费用详解

Shopify是一个让用户自主管理在线商店的平台,深受跨境电商用户喜爱,本篇文章将详细为您介绍Shopify费用都包括哪...

跨境电商建站:如何选择一个优质的外贸网站域名?

作为一名出色跨境电商从业者,建立外贸网站时,优质的域名起到至关重要的角色,一个好的域名不仅可以提升流量和收录排名,还更容...
返回顶部